Bug or not Bug?

News and info about current and upcoming releases of the game client and server.
Post Reply
User avatar
romfis
Private First Class
Private First Class
Posts: 215
Joined: Tue Jan 18, 2005 6:33 pm
Location: Österreich / Wien
Contact:

Bug or not Bug?

Post by romfis » Thu Jul 21, 2005 8:16 pm

HI all

can were on "system windows" the maps starting on server, with correct
showing?

http://www.garrettsites.net/bzmaps/inde ... tail&id=17

http://www.garrettsites.net/bzmaps/inde ... tail&id=16

and the map "Giza Plateau by Aribeth" from "Sleepycows" server, not correct starting on my "System Windows SP2"

In German:
Ewtl. kann das wer Übersätzen in "English" was ich meine!
Die drei oberen Maps Funktionieren auf anderen Betriebsystemen nur auf Windows Funktionieren die nicht, wie ich das sehe,
es kommen dann solche meldungen von server:
http://www.bzflag.at/bilder/bugs/beta_2 ... server.png
und die maps hab nicht ich gemacht, also die sollten ganz sicher funktionieren *gg* siehe z.b. bei den beiden maps auf "garrettsites".

Und mein BZServer Version ist die 2.0.3b11 da funktionierts biss heute noch immer nicht, ich kenne den BUG oder was auch immer seit der Version "2.0.0"

Ich bin in der Meinung das "bzfs.exe" nicht alle commands versteht als bei andere Systemen.

Also wenn wer mir die Antwort geben kann was ich da falsch mache oder wie ich die Maps Richtig an meinen server starten kann (kein Anfanger am PC!) oder doch ein BUG? ;)

Edit:
noch ein beispiel gefunden:
Image
kann wer dieses Tor wie hier am Foto genauso starten ohne das es falsch angezeigt wird am Windows Server - bzfs.exe ?
Also: Ich zumindest nicht, und habe dieses Tor noch nie an einem anderen Windows Server gesehen.

Da ist die Falsche anzeige von dem Tor auf Giza Plateau z.b.!
http://www.bzflag.at/bilder/bugs/beta_2 ... enshot.png

Sorry my, English is not Good, one german User Translate in English, PLEASE :D *gg*

mfg.
romfis

User avatar
Saturos
Art Master General
Art Master General
Posts: 1111
Joined: Mon Apr 19, 2004 2:48 pm
Location: Berlin/Germany
Contact:

Post by Saturos » Thu Jul 21, 2005 8:41 pm

Translation:
---------------------------------------------------------------

The three maps I mentioned above run fine in any bzfs except on windows.
bzfs.exe gives this kind of errors: http://www.bzflag.at/bilder/bugs/beta_2 ... server.png
To clarfify: I didn't make the maps, so they should work properly - see mapatorium for details.

I have the bzfs-version from 2.0.3b11 and with that build it doesn't work - I know the bug since the 2.0.0-release.

So I draw the conclusion that bzfs.exe isn't able to understand all commands that bzfs can handle on other operating-systems.

So it would be great if somebody could help me running these maps correctly on my windows-machine (xp SP2) - I am not a newbie, so maybe it's really a bug in the windows-version of bzfs?

Another example:
http://bzflag.saturos.de/future/future3.jpg
Is anybody able to start the map which includes this special teleporter on windows without getting errors? I wasn't and so far I haven't seen any windows-server running this map-object correctly.

-----------------------------------------------------------------------
Hope this helps. :)

User avatar
romfis
Private First Class
Private First Class
Posts: 215
Joined: Tue Jan 18, 2005 6:33 pm
Location: Österreich / Wien
Contact:

Post by romfis » Thu Jul 21, 2005 8:51 pm

Oh
Thanks Saturos!
for Translation :)

mfg.
romfis

User avatar
DTRemenak
General
General
Posts: 625
Joined: Thu Jan 16, 2003 4:54 am
Location: U.S.
Contact:

Post by DTRemenak » Thu Jul 21, 2005 9:40 pm

I will look at this next time I'm in windows. I've verified that the bug does exist (comparing bzfs on wine and linux) and narrowed it down. Thanks Romfis for the links to worldfiles and Saturos for the translation. It seems to be a "difference of opinion" between GCC and VS on some chunks of code in BzMaterial.cxx.

Edit - this has been fixed in cvs.

User avatar
romfis
Private First Class
Private First Class
Posts: 215
Joined: Tue Jan 18, 2005 6:33 pm
Location: Österreich / Wien
Contact:

Post by romfis » Fri Jul 22, 2005 7:20 pm

Oh Thanks! :)

can testing on 2.0.3b12 or no? *lol*

mfg.
romfis

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest