Help! BZF screen is small like Windowed, Radeon 7000

News and info about current and upcoming releases of the game client and server.
Post Reply
User avatar
Para_Shooter
Private First Class
Private First Class
Posts: 16
Joined: Sun Oct 30, 2005 3:47 am
Location: AZ

Help! BZF screen is small like Windowed, Radeon 7000

Post by Para_Shooter » Wed Jan 04, 2006 7:55 pm

Hi gurus... running 2.0.4 on Win XP, with ATI Radeon 7000 (Diamond?) 32M, OpenGL. SiS Motherboard, AMD Sempron 2200 1.5MHz, 512MB. The whole setup used to work OK, till was run once in "windowed" mode, with the little screen in its own window.

Now, regular mode still only occupies the small section of screen the Window took up, and very bad things are happening... like, a right click (to spawn) actually drops the BZF screen and brings up the context menu for the display (as though the BZF screen is not even really there). The WinXP wallpaper and icons show where the BZF screen doesn't cover, and some other "crunched" items like a mis-displayed task bar and just a black area are also showing. It's really messed up, and only for BZF.

I can't find anything in my ATI config screens, the OpenGL part or anywhere else, that helps with this. ?? Anybody seen this before? Any ideas?

I deinstalled and reinstalled the 2.0.4 Windows BZF, didn't help. I have reset the OpenGL and Direct3D to defaults (no effect).
All your base are belong to me, make your time.

User avatar
Para_Shooter
Private First Class
Private First Class
Posts: 16
Joined: Sun Oct 30, 2005 3:47 am
Location: AZ

Post by Para_Shooter » Wed Jan 04, 2006 8:19 pm

OK, an update and a question.

Update: BZF works OK, even the right-click, as long as the cursor is over the screen area for BZF (top left part of the screen). Just as in windowed mode, if your cursor strays out of the area and you left or right click, you end up "deselecting" BZF in favor of whatever window or background you have clicked on. As long as I only go forward and mostly go left, I'm fine. Every time I have to back up and shoot, I lose the BZF screen, and when I get it back I'm dead (the sitting duck effect).

Question -- is there anyplace that BZF keeps the screen size, that may be the culprit here? It's acting a lot like it is only using some fixed screen size, rather than grabbing the whole screen for full-screen mode. I'd think that a deinstall/reinstall would fix that, but... ???

Thanks!
All your base are belong to me, make your time.

User avatar
The Red Baron
Sergeant First Class
Sergeant First Class
Posts: 987
Joined: Sat Dec 07, 2002 6:21 am
Contact:

Post by The Red Baron » Wed Jan 04, 2006 8:43 pm

In bzflag. go to Options, then Display settings, and change video format.

I run windows 2000, with a radeon 7000, and a setup very similar to yours. I had the same problem. And the work around was to change the video format, (default was 1024x768 32bit) To 1024x768 16bit, and then change it back to my default.

If that doesn't work...

then delete this file

Code: Select all

C:\Documents and Settings\%user\My Documents\My BZFlag Files\2.0\config.cfg
That will reset all the settings for bzflag. If you have custom key mapping, radar settings... etc etc. You will have to re-program them.
Beware! I'm going to clone myself and spread those clones all over the world!

AlliedArmour
Sergeant
Sergeant
Posts: 831
Joined: Thu Jul 14, 2005 1:29 am
Contact:

Post by AlliedArmour » Fri Jan 06, 2006 6:23 pm

I find that this happens whenever I use Windowed mode, it'll change the regular mode - the only way to permanently fix it is to delete the config file as Baron said.

User avatar
Matt?
Private First Class
Private First Class
Posts: 281
Joined: Sun Jan 09, 2005 10:15 pm
Location: st. john wa
Contact:

Post by Matt? » Sun Jan 08, 2006 2:13 am

ou do know to get to full screen mode from windowed is easy. just press f1
Image

User avatar
(Dvn)
Private First Class
Private First Class
Posts: 80
Joined: Thu Nov 03, 2005 12:17 am
Location: U.S. S.L.C Utah
Contact:

Post by (Dvn) » Sun Jan 08, 2006 3:57 pm

i just open up the 'windowed bzflag' that was installed
Owner@gnurux.homelinux.net:5159
Owner@YOUR DEAD's
Admin/Owner@No Guts No Glory's
Admin@Win Xp's
Admin@Lddw's Admin@SirKay's
Admin@Theme97's
Admin@A Heart Attacks's
Cop@AlliedArmours
Ducati member@Teh g33ks

Image

User avatar
blast
General
General
Posts: 4741
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Post by blast » Sun Jan 08, 2006 7:14 pm

There is a geometry line in the config that controls the size of a windowed client. If this is left in, it will also affect the fullscreen mode until you press F1 twice. Delete that line from your config, and it should work. You could also run bzflag as follows:

Code: Select all

bzflag.exe -geometry default
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
Para_Shooter
Private First Class
Private First Class
Posts: 16
Joined: Sun Oct 30, 2005 3:47 am
Location: AZ

Thanks all!! Got it back to normal...

Post by Para_Shooter » Fri Feb 24, 2006 1:10 am

Thanks for the helpful posts. The details I was missing were the config file location, and where the layout geometry could be set in Options.

I find the config file location regrettable, as Windows has an 'applications' section for such things (under documents and settings\<user>\Application Settings). Putting it under <My Documents>? Kinda wierd, but, BZF wasn't really developed with Windows in mind, I guess.

Anyway, it's better now, and I thank all who took the time to bend a synapse or two my way. Thx!!

(PS: that doesn't mean I won't shoot you all next time I have you in my sights on the other team... I'll just shoot gently)
All your base are belong to me, make your time.

User avatar
Matt?
Private First Class
Private First Class
Posts: 281
Joined: Sun Jan 09, 2005 10:15 pm
Location: st. john wa
Contact:

Post by Matt? » Fri Feb 24, 2006 1:15 am

no prob
Image

Post Reply