Page 1 of 1

Eh... stumped.

Posted: Thu Mar 23, 2006 11:05 pm
by L4m3r
so I've made this single unit for a pattern-based map I'm making... testing it out... and I get stuck, like with the normal/2.0 object conflict issue. Thing is, both objects are 2.0 objects! and the kicker is, this is using replicated units, and of three, only one seems to have this problem. o_O

If anyone has a minute, please test and confirm the problem (drive around on the thing in the middle and see what happens), and provide a suggestion on how to fix this if you can think of one... :?

Posted: Fri Mar 24, 2006 9:40 am
by Spazzy McGee
argh, this is the dodgy meshbox problem. I get this all the time, as my maps are almost entirely meshboxes and arcs. it was a serious problem in my collab corner.

so far i havn't found any solution to it. prehaps somebody could shed some light? i always end up having to change the map totally.

and another thing - it seems to happen totally randomly. I have tried as many ways as i can think of to induce the proble, and it only seems to happen when i don't want it to. :P

Posted: Mon Mar 27, 2006 7:51 am
by L4m3r
Tried making actual mesh boxes instead of meshboxes. No help.

tried rotating it differently. That only changed which seams catch. It's almost like the client has issues with the seams when they're at certain angles. -_-

Posted: Mon Mar 27, 2006 12:46 pm
by Teppic
Turn the whole thing into one mesh, use the same vertices for the petal things as the box sections and it should work, if not define some inside points too.

Posted: Mon Apr 24, 2006 10:00 am
by L4m3r
Okay, I think I've finally figuring out some conditions under which this glitch happens. It seems to have something to do with grouping and spin transformations.

I can't pin it down exactly, but it looks like this glitch occurs between objects that are of different "levels" of grouping and have gone through different numbers of spin transformations.

Does this ring a bell or bring out a pattern for anyone?

Posted: Mon Apr 24, 2006 10:15 am
by Spazzy McGee
yeah, i regularly spin/rot groups, so this is probably it....

Posted: Mon Apr 24, 2006 10:47 am
by ClayOgre
Is this where we supposedly have two meshes that are on the same level/height, but the tank can't drive over them? Or can drive over the seam one way, but not the other?

Posted: Mon Apr 24, 2006 11:40 am
by Spazzy McGee
yes. and it's insanely annoying.

as far as i can see, it happens when you have groups nestled in groups

Posted: Tue Apr 25, 2006 1:21 am
by LouMan
I have had problems with that on my LegoLand map - the only way I could fix it was to define the object as one big mesh instead of trying to build it by replicating and rotating smaller objects.

Posted: Tue Apr 25, 2006 2:05 am
by ClayOgre
I did something in my collab corner...but I dunno if I really fixed it or not. I left a small gap between the two objects, like .01 or something. I had no trouble, but somebody who was texting the map for me said they did. It was hard to tell, since one of the objects had two linear physics drivers.

Posted: Mon May 08, 2006 12:13 am
by TD-Linux
I've had this problem too...
Is there a variable to change that fixes this? I played on a HiX map a while ago (it may have been 2.1, I forgot) that you could drive up to a wall and instantly go on top of it. Maybe this would fix the problem, but I don't know the variable name.