API changes for v. 2.4

Questions, comments, and news on the server side plug-ins and it's API
Post Reply
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5119
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

API changes for v. 2.4

Post by JeffM » Wed May 18, 2011 6:05 pm

We have made some breaking changes to the API for version 2.4.

Plug-ins written for 2.0.x will not load in BZFS 2.3.4 or later.

I have written up a basic document on the changes to the API and some step by step on how to upgrade plug-ins. here http://my.bzflag.org/wiki/index.php?tit ... .4_Upgrade

All of the standard plug-ins have been updated to be used as samples as well.

Once plug-ins are upgraded to 2.4 they will not load in 2.0.x but will not require changes for future versions ( not even a recompile)

User avatar
allejo
Breaker of Builds
Breaker of Builds
Posts: 648
Joined: Sun Feb 17, 2008 10:01 pm
Location: /dev/null
Contact:

Re: API changes for v. 2.4

Post by allejo » Tue Jun 14, 2011 8:36 pm

Thanks for the new documentation Jeff. it's very appreciated :D I'm assuming the plugins distributed with BZFlag 2.3 are already in the new format so they can be used as examples?
Here's my personal website and my open source projects are available on GitHub; I work on a lot of cool things.

Image

User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5119
Joined: Fri Dec 13, 2002 4:11 am
Location: [Redacted]
Contact:

Re: API changes for v. 2.4

Post by JeffM » Tue Jun 14, 2011 8:38 pm

Yes everything in the source tree has been updated

User avatar
allejo
Breaker of Builds
Breaker of Builds
Posts: 648
Joined: Sun Feb 17, 2008 10:01 pm
Location: /dev/null
Contact:

Re: API changes for v. 2.4

Post by allejo » Tue Jun 14, 2011 8:40 pm

Good to know. Thanks for the info.
Here's my personal website and my open source projects are available on GitHub; I work on a lot of cool things.

Image

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests