i don't get a .so

Questions, comments, and news on the server side plug-ins and it's API
Post Reply
User avatar
khazhyk
Private First Class
Private First Class
Posts: 1400
Joined: Sun Feb 06, 2005 5:40 pm
Location: Somewhere over there.
Contact:

i don't get a .so

Post by khazhyk » Sat Feb 18, 2006 5:28 pm

i'm trying to compile the HTF plugin, but all i get is a .o file and a .lo file. i read the "where's the .so?" topic but it didn't help.
Image

User avatar
RPG
Lieutenant, Junior Grade
Lieutenant, Junior Grade
Posts: 2015
Joined: Fri Sep 17, 2004 2:37 am
Location: Chicago, Illinois
Contact:

Post by RPG » Sat Feb 18, 2006 5:39 pm

have you done a "locate <pluginname>.so"?

User avatar
khazhyk
Private First Class
Private First Class
Posts: 1400
Joined: Sun Feb 06, 2005 5:40 pm
Location: Somewhere over there.
Contact:

Post by khazhyk » Sat Feb 18, 2006 5:41 pm

I have now, but nothing.
Image

User avatar
I_Died_Once
Special Forces
Special Forces
Posts: 635
Joined: Sun Nov 28, 2004 5:27 pm
Location: The Dark Side
Contact:

Post by I_Died_Once » Sat Feb 18, 2006 6:11 pm

Not sure how much help this is...

I'm on Suse linux, and when I compile, I use the --prefix=/path/to/bzflag when running ./configure so that my binaries and everything goes into my desired directory. I save the source in the home directory and use the prefix so mine goes into /home/death/bzflag/

As far as the plugins, I always find mine in /home/death/bzflag/libs/ And yes, I am specifically talking about the .so files. (they call me the plugin King behind my back)

I might be off going from memory (not at home) but I find mine in a /libs/ folder somewhere in the bzflag source.

So if you can't find yours, consider using a --prefix

This is all assuming that when you compile, you do both a "make" *A*N*D* a "make install"

Good luck
...This has been a recording.

User avatar
khazhyk
Private First Class
Private First Class
Posts: 1400
Joined: Sun Feb 06, 2005 5:40 pm
Location: Somewhere over there.
Contact:

Post by khazhyk » Sat Feb 18, 2006 6:18 pm

i do make and make install, and i have no "libs" folder in the bzflag dict.
Image

User avatar
Tropican8
Private First Class
Private First Class
Posts: 312
Joined: Fri Mar 18, 2005 11:51 pm
Location: As close to the grove as you can get

Post by Tropican8 » Sat Feb 18, 2006 7:39 pm

me1,

Try ./configure --enable-shared --enable-plugins

After make and make install, they should be in a /lib as Darth said. That's /usr/local/lib if you do a checkinstall or default (no argument) make install.

User avatar
khazhyk
Private First Class
Private First Class
Posts: 1400
Joined: Sun Feb 06, 2005 5:40 pm
Location: Somewhere over there.
Contact:

Post by khazhyk » Sat Feb 18, 2006 7:51 pm

i'll try that
EDIT: nope :( I still get no .so... :(
EDIT2: I talk to some guy on IRC and solved the prob.
Image

Longhair
Private First Class
Private First Class
Posts: 330
Joined: Tue Feb 08, 2005 6:06 pm
Location: Lancaster, PA
Contact:

Post by Longhair » Thu Feb 23, 2006 2:07 pm

And the solution was....?

FWIW, ./configure --enable-shared has always worked for me.

User avatar
khazhyk
Private First Class
Private First Class
Posts: 1400
Joined: Sun Feb 06, 2005 5:40 pm
Location: Somewhere over there.
Contact:

Post by khazhyk » Thu Feb 23, 2006 2:45 pm

it seemed that the folder with the plugins was hidden :|
Image

Post Reply