Page 1 of 1

plugin troubleshooting - can't load?

Posted: Tue Jul 03, 2018 5:32 pm
by musculargenius
How can I troubleshoot this error? Seems I'm unable to load plugins. Is this because I'm not running bzfs as root? Looks like all plugin .so files are 0644 so I don't see why it's a problem...

Code: Select all

WARNING: unable to load the plugin; chathistory
WARNING: unable to load the plugin; autoFlagReset
Sorry if folks are getting tired of my questions! I'm just trying to make the best servers possible, to be a good bzflag steward/citizen.

Re: plugin troubleshooting - can't load?

Posted: Tue Jul 03, 2018 5:42 pm
by musculargenius
I should clarify that I've tried all forms of -loadplugin -- all with the same results

-loadplugin chathistory # FAILS
-loadplugin chathistory.so # FAILS
-loadplugin /usr/lib/bzflag-server/chathistory.so # FAILS

...as well as all of the above 'in quotes' (as in -loadplugin 'chathistory', etc, etc)

The only thing I haven't tried doing is changing ownership over the plugin files to the user running bzfs...

Re: plugin troubleshooting - can't load?

Posted: Tue Jul 03, 2018 5:51 pm
by musculargenius
ok... seeing more of what's going on. the plugins that came with the server package on Debian 9 don't appear to be compatible with the bzfs server they shipped with. Running bzfs with -ddd yielded this extra insight:

Code: Select all

Jul 03 12:48:15 waki bzflagserver01[25577]: Plugin: chathistory found but does not contain bz_GetPlugin method, error /usr/games/bzfs: undefined symbol: bz_GetPlugin
So I'm guessing I should run a custom-compiled version of bzfs??

Re: plugin troubleshooting - can't load?

Posted: Tue Jul 03, 2018 6:03 pm
by musculargenius
ok that was it! the bzflag server that comes packaged with debian 9 (latest stable release) has issues. I compiled my own bzfs and plugins from source and they load just fine. The mystery is solved. Thanks for playing!

Re: plugin troubleshooting - can't load?

Posted: Tue Jul 03, 2018 9:19 pm
by blast
For what it's worth, I didn't seem to have a problem loading the plugins with the 2.4.8 bzfs that Debian 9 ships. Regardless, I don't suggest using the packaged server anyway because it's generally going to be outdated and it automatically runs a copy of bzfs.

Re: plugin troubleshooting - can't load?

Posted: Fri Jul 13, 2018 7:01 pm
by alfa1
Is this because I'm not running bzfs as root?
Never run bzfs (or any other server within possible) as the root user due to security risks.
musculargenius wrote:
Tue Jul 03, 2018 5:32 pm
I'm just trying to make the best servers possible, to be a good bzflag steward/citizen.
Good for that!

Just in case: Compiling on Linux - Help for Beginners (and Not So Beginners) .

Re: plugin troubleshooting - can't load?

Posted: Sat Jul 14, 2018 2:37 am
by musculargenius
alfa1 wrote:
Fri Jul 13, 2018 7:01 pm
Is this because I'm not running bzfs as root?
Never run bzfs (or any other server within possible) as the root user due to security risks.
musculargenius wrote:
Tue Jul 03, 2018 5:32 pm
I'm just trying to make the best servers possible, to be a good bzflag steward/citizen.
Good for that!

Just in case: Compiling on Linux - Help for Beginners (and Not So Beginners) .
No need to worry. I would never run it as root even if that's the only way it ran. As the saying goes, I was born at night, but I wasn't born last night. ;-)