Page 1 of 1

BzFlag-Server ----->>> HELP!!!!

Posted: Sun May 28, 2006 4:33 pm
by Zelgadis
Hi all!

My friend and I, want to make a BZFlag-Server, we have do all things but when we will to start it, it comes this:

require UDP clients!
using time limit of 1800 seconds
bad argument "Kommentar"
BZFlag server (protocol 0026)
Copyright (c) 1993 - 2005 Tim Riker

Usage: bzfs [-a <vel> <rot>] [-admsg <text>] [-autoTeam] [-b] [-badwords <filena
me>] [-ban ip{,ip}*] [-banfile <filename>] [-c] [-cache <url prefix>] [-cacheout
<filename>] [-conf <filename>] [-cr] [-d] [-density <num>] [-disableBots] [+f {
good|<id>}] [-f {bad|<id>}] [-fb] [-filterCallsigns] [-filterChat] [-filterSimpl
e] [-g] [-groupdb <group file>] [-h] [-handicap] [-helpmsg <file> <name>] [-i in
terface] [-j] [-lagdrop <num>] [-lagwarn <time/ms>] [-masterBanURL <URL>][-maxid
le <time/s>] [-mp {<count>|[<count>][,<count>][,<count>][,<count>][,<count>][,<c
ount>]}] [-mps <score>] [-ms <shots>] [-mts <score>] [-noMasterBanlist][-noradar
][-p <port>] [-passdb <password file>] [-passwd <password>] [-pidfile <filename>
] [-poll <variable>=<value>][-printscore] [-public <server-description>] [-publi
caddr <server-hostname>[:<server-port>]] [-publiclist <list-server-url>] [-q] [+
r] [-rabbit [score|killer|random]] [-recbuf <Mbytes>] [-recdir <dirname>] [-repl
ay] [-reportfile <filename>] [-reportpipe <filename>] [-requireudp] [+s <flag-co
unt>] [-s <flag-count>] [-sa] [-sb] [-set <name> <value>] [-sl <id> <num>] [-spa
mtime <time>] [-spamwarn <warnAmt>] [-speedtol <tolerance>] [-srvmsg <text>] [-s
t <time>] [-sw <num>] [-synctime] [-synclocation] [-t] [-tftimeout <seconds>] [-
time <seconds>] [-timemanual] [-tk] [-tkkr <percent>] [-userdb <user permissions
file>] [-vars <filename>] [-version] [-world <filename>] [-worldsize <world siz


I don't know how to repair it, please HELP!

And sorry for my bad English! :oops:

Posted: Sun May 28, 2006 4:42 pm
by A Meteorite
Find the text "Kommentar" in either your command or configuration file. Apparently it was wrapped to a new-line without a comment symbol (#). Better yet, post your configuration file here without the password. :)

Posted: Wed May 31, 2006 1:31 pm
by JPT
Bitte gebt uns mal das Komando, mit dem ihr den Server gestartet habt,
und auch die Karte und die Einstellungsdatei.

(In this case, my german is necessary ;) )

Posted: Wed Jun 28, 2006 1:10 pm
by Zelgadis
Yeah! it works now!


Für dich:

Wenns windows hast, dann gebe in CMD ein, den pfad vom "bzfs" dann den pfad von "conf" ein!

Bsp bei mir:

C:/Server/hix/bzfs -conf C:/Server/hix/config.conf

Posted: Sat Jul 01, 2006 4:01 pm
by JPT
Lol, du hast die Config-Datei nicht angegeben... *rofl*