Mac server worldfile issue?

Need help seting up a server, or have a question on how to run one? This is the place.
Post Reply
Xalendare
Private First Class
Private First Class
Posts: 13
Joined: Sat Jun 03, 2006 7:44 pm

Mac server worldfile issue?

Post by Xalendare » Fri Jun 09, 2006 8:26 pm

Hello, I'm new to both the forums and the idea of running a server, and I'm having some issues with getting worldfiles/maps to work on my server.

So far, I've been playing randomly generated maps with friends, but I've recently tried to download a few maps and run those, to no avail. I've tried adding a map to the server config file using the flag "-world [path to file]", but Terminal keeps dumping out the following message:

Code: Select all

error: could not find bzflag world file
error: unexpected EOF
error: world file failed to load.
ERROR: A world was not specified
I've checked the path several times, its good. Any ideas what I'm doing wrong?
Last edited by Xalendare on Sat Jun 10, 2006 3:41 am, edited 1 time in total.

User avatar
The Knights Who Say Ni
Private First Class
Private First Class
Posts: 556
Joined: Mon Sep 26, 2005 7:21 pm
Location: Uplyme, England
Contact:

Post by The Knights Who Say Ni » Fri Jun 09, 2006 9:56 pm

it basically means that in youre map file at the End Of File [EOF] you are missing an end or something
Image
Sig Made By AlliedArmour

TGPH

Xalendare
Private First Class
Private First Class
Posts: 13
Joined: Sat Jun 03, 2006 7:44 pm

Post by Xalendare » Sat Jun 10, 2006 3:38 am

It's a map I downloaded from BZFlag Mapatorium, and I know nothing about mapmaking. How do I fix this?

By the way, I've tried two maps, same error. It occurs to me that it might have something to do with the fact I'm on a Mac, perhaps different formatting. Any ideas?

User avatar
CannonBallGuy
Private First Class
Private First Class
Posts: 2083
Joined: Wed Apr 12, 2006 1:31 am
Contact:

Post by CannonBallGuy » Sat Jun 10, 2006 8:57 am

Shouldn't matter that you're on OS X. Never did for me.

Show us your conf file, map file and the whole output in terminal. :)
Image

Merry Christmas!

"Look, if I don't buy booze for the kids, I don't get any incriminating pictures to show to their parents, my business goes down the sink, my girlfriend leaves me and the baby goes on ebay. So help me search..."

"go Play With Toys urself in a dark alley u donkey ******" - Lt-Kirby2007

User avatar
A Meteorite
Private First Class
Private First Class
Posts: 1786
Joined: Thu Apr 28, 2005 12:56 am
Location: California, U.S.
Contact:

Post by A Meteorite » Sat Jun 10, 2006 6:00 pm

I get this occasionally on Mac OS X. It's seems related to the formatting - or lack of - on the first line (at least that's how I fixed it) but I can't seem to reproduce the problem right now. :?

Maybe try saving the file in TextEdit as UTF-8 or possibly some other formats and see if that does anything? Also run bzfs with "-d -d -d -d" to get more debug output.

And as CannonBallGuy said: please post everything involved in the server (config file and map).
Image
Owner @ BZFX
Core Admin @ CAN

Email me: bzmet…@gmail.com

Xalendare
Private First Class
Private First Class
Posts: 13
Joined: Sat Jun 03, 2006 7:44 pm

Post by Xalendare » Sat Jun 10, 2006 9:27 pm

The files and Terminal output, as requested.

Terminal shell: (personal info removed, ask me if its necessary.)

Code: Select all

c-[IP address]:~/Games/Shooters/BZFlag/BZFlag-2.0.8.app/Contents/MacOS [username removed]$ ./bzfs -conf ~/bzfsmap.conf
using spam time of 10
using spam warn amount of 40
~/Games/Shooters/BZflag/Maps/FFA/kingcastle.bzw: error: could not find bzflag world file
~/Games/Shooters/BZflag/Maps/FFA/kingcastle.bzw: error: unexpected EOF
~/Games/Shooters/BZflag/Maps/FFA/kingcastle.bzw: error: world file failed to load.
c-[IP address]:~/Games/Shooters/BZFlag/BZFlag-2.0.8.app/Contents/MacOS [username removed]$
EDIT: Heh, heh, all that and I forgot to block out the Admin Password in the conf file. *Slaps forehead* Guess I'll be changing that...
Attachments
bzfsmap.conf.txt
Configuration file (.txt extension added)
(11.99 KiB) Downloaded 69 times
kingcastle.bzw
Map file
(20.19 KiB) Downloaded 80 times

Xalendare
Private First Class
Private First Class
Posts: 13
Joined: Sat Jun 03, 2006 7:44 pm

Post by Xalendare » Sun Jun 11, 2006 9:01 pm

I'm sorry to bump this thread, but I could really use some help...

trepan
Dev Wizard
Dev Wizard
Posts: 704
Joined: Fri Feb 21, 2003 7:50 pm

Post by trepan » Sun Jun 11, 2006 9:07 pm

Tilde expansion does not occur in -conf files.
Try using the full path, ex:
/home/trepan/bzflag/maps/map.bzw
(instead of ~/bzflag/maps/map.bzw)

Xalendare
Private First Class
Private First Class
Posts: 13
Joined: Sat Jun 03, 2006 7:44 pm

Post by Xalendare » Sun Jun 11, 2006 9:11 pm

trepan wrote:Tilde expansion does not occur in -conf files.
Try using the full path, ex:
/home/trepan/bzflag/maps/map.bzw
(instead of ~/bzflag/maps/map.bzw)
Hah! That was it! Many, many thanks.

User avatar
BinarySpike
Corporal
Corporal
Posts: 735
Joined: Mon Mar 28, 2005 11:58 pm
Contact:

Post by BinarySpike » Tue Jun 13, 2006 5:38 pm

Tilde expansion does not occur in -conf files.

Whoa... I never knew...


By the way, there seems to be formatting problems every once in a while in certain maps...

To overcome this problem I open my maps in Project Builder (for 10.3+ users the eqivilent would be xcode) and I would convert it from whatever format to UTF-8

This can also be done in text edit but I've never tried so I can't be sure it works ;-)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest