Blending (Display setting) causes blurry edges in radar

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
User avatar
leviathan
Private First Class
Private First Class
Posts: 43
Joined: Mon Jan 02, 2006 6:41 pm
Location: Sweden

Blending (Display setting) causes blurry edges in radar

Post by leviathan » Sat Jul 20, 2013 6:29 pm

Huhu everybody,

under version 2.4.2 I have a problem with the radar, which I don't have under 2.4.0, and which I want to explain here.

I am using a non-transparent radar and in the display settings I have "blending - on"
While under 2.4.0 these settings provided me a sharp radar, in 2.4.2 I need to turn "blending - off" in order to not get a radar that looks like this:
Image

The blurry edges get really extreme, when the tank is turning. Dodging a double or triple is not easy.
And maybe a hint that could help: By simply pressing the ESC button, I am in the menu while in the background I don't see the mentioned problem anymore.

So I have the following choices:
- either I keep playing under 2.4.0, skip 2.4.2 and hope for the next version
- or I could just turn "blending - off", but I absolutely hate the way the bullets look like on the "real screen" (not in the radar, where everything is sharp).

Which leads me to my question:
Is there a way to turn "blending - on" for the non-radar view and "blending - off" for the radar? Maybe a simple command in the config file?
Or do you maybe remember what you altered between the two mentioned versions and can undo it in for the next release?

More screenshots/infos needed? Just tell me.

I know this is not a big issue that anyone would want to solve immediately, so I would totally understand if nobody wants to go find the cause. So I would just live with it and go by one of the two coices I mentioned above.

Thanks for reading,
best wishes and see you on the battlefield,
levi

User avatar
blast
General
General
Posts: 4741
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Blending (Display setting) causes blurry edges in radar

Post by blast » Sat Jul 20, 2013 6:37 pm

I'm not seeing the same issue in my 2.4.2. Could you take a screenshot of your display settings and GUI settings pages? Additionally, what operating system, video card, and video driver are you using?
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
leviathan
Private First Class
Private First Class
Posts: 43
Joined: Mon Jan 02, 2006 6:41 pm
Location: Sweden

Re: Blending (Display setting) causes blurry edges in radar

Post by leviathan » Sat Jul 20, 2013 6:52 pm

My display settings:
Image

My GUI settings:
Image

My OS: Mac OS X Lion 10.7.5

My video card: Intel HD3000

My driver: BZFlag says:
OpenGL Driver: Intel HD Graphics 3000 OpenGL Engine

Thanks blast!

User avatar
blast
General
General
Posts: 4741
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: Blending (Display setting) causes blurry edges in radar

Post by blast » Sat Jul 20, 2013 7:38 pm

Okay, here's the problem. I think between 2.4.0 and 2.4.2 we split the opacity controls for the panel and the radar, but we missed the case where someone had the opacity set to the max with an old config. So, make sure both the panel and radar opacity are set to the highest setting.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image

User avatar
leviathan
Private First Class
Private First Class
Posts: 43
Joined: Mon Jan 02, 2006 6:41 pm
Location: Sweden

Re: Blending (Display setting) causes blurry edges in radar

Post by leviathan » Sat Jul 20, 2013 7:48 pm

Thanks a lot blast, that solved my problem!! Should've played around with these settings more to find out by myself..

Best wishes,
levi

*oh and you can close/delete this thread, i think this was a very exclusive problem*

Post Reply