Centrum/BZFS User Database

NOTE: this is an informal bug post place ONLY. Real bugs should be posted on GitHub
Post Reply
User avatar
Sir Lance-A-Lot
Private First Class
Private First Class
Posts: 503
Joined: Tue Jun 29, 2004 12:49 am
Location: Amongst my Computers
Contact:

Centrum/BZFS User Database

Post by Sir Lance-A-Lot »

OK so I'm runnin my 2.0 server at camelot.myvnc.com:5154.
Recieved a report that a registered Centrum member didnt have the "+" sign before their name.
Also - whenever I log in - I dont even have the "+" sign.
What is the BZFS .conf command for this? I dont think its in my config.
Image
User avatar
RPG
Lieutenant, Junior Grade
Lieutenant, Junior Grade
Posts: 2015
Joined: Fri Sep 17, 2004 2:37 am
Location: Chicago, Illinois
Contact:

Post by RPG »

I was talking to somebody else that didn't have their + sign, and it turned out they waited a few days and it popped up. A delay i'm guessing? Or was she doing something wrong and fixed it without telling me?

Anyways, from what i've experienced I think it's a delay.
User avatar
Sir Lance-A-Lot
Private First Class
Private First Class
Posts: 503
Joined: Tue Jun 29, 2004 12:49 am
Location: Amongst my Computers
Contact:

Post by Sir Lance-A-Lot »

would that also delay the "identify" command? Would it cause that to delay also?
Image
User avatar
RPG
Lieutenant, Junior Grade
Lieutenant, Junior Grade
Posts: 2015
Joined: Fri Sep 17, 2004 2:37 am
Location: Chicago, Illinois
Contact:

Post by RPG »

If it is a delay, theoretically it would delay identify too, because tokens and identifying draw from the same database.
User avatar
Sir Lance-A-Lot
Private First Class
Private First Class
Posts: 503
Joined: Tue Jun 29, 2004 12:49 am
Location: Amongst my Computers
Contact:

Post by Sir Lance-A-Lot »

hmm...The only way someone gets the signs there is if they identify - I am sure theres a config switch im missing...Like for global login?
Image
User avatar
RPG
Lieutenant, Junior Grade
Lieutenant, Junior Grade
Posts: 2015
Joined: Fri Sep 17, 2004 2:37 am
Location: Chicago, Illinois
Contact:

Post by RPG »

No, global login works on my server and I have no special switch.
User avatar
bryjen
Brigadier General
Brigadier General
Posts: 60
Joined: Thu Dec 12, 2002 1:28 am
Location: IN, US

Post by bryjen »

The /identify, /register, and like commands only operate on user info stored in local files on the bzfs machine. You don't need them anymore using forum accounts.
"Waited a few days" ? Perhaps you mean several seconds, or a couple of minutes? There was next to no delay in the old /identify system. The new system has to communicate over the 'net with the forum, so it can take a moment or two.
User avatar
Scorch
Private First Class
Private First Class
Posts: 747
Joined: Thu Sep 30, 2004 12:16 am

Post by Scorch »

disable the password file.
User avatar
Sir Lance-A-Lot
Private First Class
Private First Class
Posts: 503
Joined: Tue Jun 29, 2004 12:49 am
Location: Amongst my Computers
Contact:

Post by Sir Lance-A-Lot »

disable as in delete? ok - I'll take it out of the Server folder and see what it does.
Image
User avatar
RPG
Lieutenant, Junior Grade
Lieutenant, Junior Grade
Posts: 2015
Joined: Fri Sep 17, 2004 2:37 am
Location: Chicago, Illinois
Contact:

Post by RPG »

And take the -passdb line out of the CONF file.
User avatar
Sir Lance-A-Lot
Private First Class
Private First Class
Posts: 503
Joined: Tue Jun 29, 2004 12:49 am
Location: Amongst my Computers
Contact:

Post by Sir Lance-A-Lot »

Still dont work - Heres the command line im runnin off of.

Code: Select all

bzfs.exe -world Micron_CTF.map -c -public "Sir Lance-A-Lot: Running Micron_CTF by me." -ms 5 +r -j -fb -password * -f bad -admsg "Server by Sir Lance-A-Lot. Play Fair." -badwords SwearList.txt -filterChat -filterCallsigns -helpmsg admins.txt admins -helpmsg Rules.txt Rules -helpmsg contact.txt contact -lagdrop 3 -lagwarn 500 -maxidle 400 -mp 10 -reportfile report.txt -srvmsg "Welcome to Sir Lance-A-Lot's server! \nPlease play fair, no cheating and no swearing.\nRunning Micron_CTF by me.\nEnjoy!" -st 2 -sw 1 -publicaddr camelot.myvnc.com:5154 -worldsize 150X150 -p 5154 -timemanual +s 40 -d -d -d -d
Image
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5195
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Post by JeffM »

does your ISP use a transperant proxy server? if it does then you'll want to try and use port 81 for your list server. Some ISPs use a chaching proxy, and it screws up the tokens for auth.

just try adding -publiclist http://my.bzflag.org:81/db/
ImageJeffM
Post Reply