BZFlag won't launch

Help with Setup, Hardware, Performance or other Issues...Or just pimp your rig.
Post Reply
big_dog1968
Private First Class
Private First Class
Posts: 5
Joined: Sat May 10, 2008 12:34 pm

BZFlag won't launch

Post by big_dog1968 »

I installed BZFlag in Linux Mint xcfe/Hardy Heron.
When I launch I get:
X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 134 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x63
Serial number of failed request: 149
Current serial number in output stream: 151

I opened it windowed and then chaged the resolution and that seemed to work, but the setting won't save. I am having to set this every time.

Is there a way to set the resolution permanently to the desired resolution that works? The save option in the game did nothing. Is there a config file where the resolution can be edited ,manually? If so where?
:?
Longhair
Private First Class
Private First Class
Posts: 330
Joined: Tue Feb 08, 2005 6:06 pm
Location: Lancaster, PA
Contact:

Post by Longhair »

The config file is located at: ~/.bzf/2.0/config.cfg
ts
Dev Monkey
Dev Monkey
Posts: 970
Joined: Fri Jan 14, 2005 6:26 pm

Post by ts »

You should look for something like

Code: Select all

set resolution "1680x1050    "
in the config file. Obviously you are likely to use a different resolution..so replace the numbers with something you like, x is the seperator.

A friend of me had a similar problem a few days ago, too.
GU league: http://www.guleague.org/
An introduction to TCP: http://www.lafkon.net/tc/
big_dog1968
Private First Class
Private First Class
Posts: 5
Joined: Sat May 10, 2008 12:34 pm

Re: BZFlag won't launch

Post by big_dog1968 »

I have mint 6 installed now and can't find the config file. is it somewhere new in 2.0.10.20071115?
User avatar
blast
General
General
Posts: 4804
Joined: Fri Mar 21, 2003 3:49 pm
Location: playing.cxx
Contact:

Re: BZFlag won't launch

Post by blast »

The configuration file is created by BZFlag, and on linux, it gets stored in ~/.bzf/2.0/config.cfg as it always has. Are you getting some error? (What exactly is leading you to believe it can't find the config?) You could also try deleting your existing ~/.bzf/ directory if one exists.
"In addition to knowing the secrets of the Universe, I can assure you that I am also quite potty trained." -Koenma (Yu Yu Hakusho)

Image
big_dog1968
Private First Class
Private First Class
Posts: 5
Joined: Sat May 10, 2008 12:34 pm

Re: BZFlag won't launch

Post by big_dog1968 »

blast wrote:The configuration file is created by BZFlag, and on linux, it gets stored in ~/.bzf/2.0/config.cfg as it always has. Are you getting some error? (What exactly is leading you to believe it can't find the config?) You could also try deleting your existing ~/.bzf/ directory if one exists.
The problem was that the /.bzf/2.0/config.cfg file was not created at installation by Synaptic. the folder was not even there. The .bzf directory was in my home folder, but not the /2.0 sub directory. I uninstalled and then reinstalled BZFLAG, and the folder and config file were created. I was then able to set the resolution, which is always a problem on this system. My other PC never has a resolution problem, but this one does. Long story short - problem solved. Thanks for the help. :D
User avatar
JeffM
Staff Sergeant
Staff Sergeant
Posts: 5195
Joined: Fri Dec 13, 2002 4:11 am
Location: https://github.com/OmniTanks
Contact:

Re: BZFlag won't launch

Post by JeffM »

run bzflag -window -geometry 800x600 to get it to start the first time, then set your resolution.

your video driver is not reporting valid configurations for us to pick up on.
ImageJeffM
Post Reply