Weird mesh bug...I think.

Questions and answers about the how and why of making maps.
Post Reply
User avatar
ClayOgre
Private First Class
Private First Class
Posts: 227
Joined: Mon Apr 18, 2005 3:17 am
Location: Southern Indiana (originally from Alaska)

Weird mesh bug...I think.

Post by ClayOgre » Sat Jan 14, 2006 3:11 pm

I have run into this problem before with just regular prefab mesh map objects. Two objects will supposedly be at the same height, right next to each other, but you can't drive across the surfaces.

The attached code is a custom mesh that has the same problem. Basically it is a sort of rock "surround" to the main arena. There is a tunnel circumnavigating the whole arena. It is made from a sort of wedge shaped custom mesh object that is repeated four times. If you get on top of the mesh and drive counterclockwise, you cannot drive over the northwest seam between the objects . If you are driving clockwise, the same thing happens on the northeast corner. This happens inside the tunnel as well.

The southwest and southeast corners are just fine.

The object was made in wings, I have selected the faces and done a flatten in "Y", so they should all be on the same level. I don't get it.

I suppose I could just put some sort of obstacle in all the corners that you have to jump over as a workaround, but I am just baffled as to what the problem is.

If you run the code, your tank will likely spawn inside the object, just drive out into the middle. You will need one of the many wings flags to get around.

Any thoughts would be appreciated.
Attachments
surround.bzw
(19.46 KiB) Downloaded 108 times
Respectfully,
I Beg to Remain,
Cordially Yours,
Regards....

Image

Post Reply